What’s Vulnerable › Vulnerabilities
CVE-2023-48291: Apache Airflow: Improper access control to DAG resources
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-21 · updated 2026-06-17
- Weakness: CWE-668
Description
Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2 Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.
Affected products
- Apache Airflow: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/12/21/1
- https://github.com/apache/airflow/pull/34366
- https://lists.apache.org/thread/3nl0h014274yjlt1hd02z0q78ftyz0z3
- http://www.openwall.com/lists/oss-security/2023/12/21/1
- https://github.com/apache/airflow/pull/34366
- https://lists.apache.org/thread/3nl0h014274yjlt1hd02z0q78ftyz0z3
Get alerted when CVE-2023-48291 or the next vulnerability affects your stack