What’s Vulnerable › Vulnerabilities
CVE-2023-48297: Discourse vulnerable to unlimited mentioned users in message serializer
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-12 · updated 2026-06-17
- Weakness: CWE-400
Description
Discourse is a platform for community discussion. The message serializer uses the full list of expanded chat mentions (@all and @here) which can lead to a very long array of users. This issue was patched in versions 3.1.4 and beta 3.2.0.beta5.
Affected products
- discourse: before 3.1.4; 3.2.0-beta1, 3.2.0-beta2, 3.2.0-beta3 — fixed in 3.1.4
How to fix
Upgrade to a fixed version: discourse 3.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-hf2v-r5xm-8p37
- https://github.com/discourse/discourse/security/advisories/GHSA-hf2v-r5xm-8p37
Get alerted when CVE-2023-48297 or the next vulnerability affects your stack