What’s Vulnerable › Vulnerabilities
CVE-2023-48300: Embed Privacy missing escaping for show_all attribute in opt-out shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The `Embed Privacy` plugin for WordPress that prevents the loading of embedded external content is vulnerable to Stored Cross-Site Scripting via `embed_privacy_opt_out` shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 1.8.1 contains a patch for this issue.
Affected products
- Epiphyt Embed Privacy: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: Epiphyt Embed Privacy 1.8.1. Check the vendor advisory for mitigations.
References
- https://d.pr/v/ORuIat
- https://github.com/epiphyt/embed-privacy/commit/f80929992b2a5a66f4f4953cd6f46cc227154a5c
- https://github.com/epiphyt/embed-privacy/issues/199
- https://github.com/epiphyt/embed-privacy/security/advisories/GHSA-3wv9-4rvf-w37g
- https://d.pr/v/ORuIat
- https://github.com/epiphyt/embed-privacy/commit/f80929992b2a5a66f4f4953cd6f46cc227154a5c
- https://github.com/epiphyt/embed-privacy/issues/199
- https://github.com/epiphyt/embed-privacy/security/advisories/GHSA-3wv9-4rvf-w37g
Get alerted when CVE-2023-48300 or the next vulnerability affects your stack