What’s Vulnerable › Vulnerabilities
CVE-2023-48307: Nextcloud Mail app vulnerable to Server-Side Request Forgery
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-918
Description
Nextcloud Mail is the mail app for Nextcloud, a self-hosted productivity platform. Starting in version 1.13.0 and prior to version 2.2.8 and 3.3.0, an attacker can use an unprotected endpoint in the Mail app to perform a SSRF attack. Nextcloud Mail app versions 2.2.8 and 3.3.0 contain a patch for this issue. As a workaround, disable the mail app.
Affected products
- nextcloud Mail: from 1.13.0 before 2.2.8; from 3.0.0 before 3.3.0 — fixed in 2.2.8, 3.3.0
How to fix
Upgrade to a fixed version: nextcloud Mail 2.2.8, 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/mail/pull/8709
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-4pp4-m8ph-2999
- https://hackerone.com/reports/1869714
- https://github.com/nextcloud/mail/pull/8709
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-4pp4-m8ph-2999
- https://hackerone.com/reports/1869714
Get alerted when CVE-2023-48307 or the next vulnerability affects your stack