What’s Vulnerable › Vulnerabilities
CVE-2023-48362: Apache Drill: XXE Vulnerability in XML Format Reader
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-611
Description
XXE in the XML Format Plugin in Apache Drill version 1.19.0 and greater allows a user to read any file on a remote file system or execute commands via a malicious XML file. Users are recommended to upgrade to version 1.21.2, which fixes this issue.
Affected products
- Apache Software Foundation Apache Drill: from 1.9.0 before 1.21.2 — fixed in 1.21.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Drill 1.21.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/07/24/3
- https://lists.apache.org/thread/9tt0q4bdjwgw0dz0l9knqxjnpb5y6zsl
- http://www.openwall.com/lists/oss-security/2024/07/24/3
- https://lists.apache.org/thread/9tt0q4bdjwgw0dz0l9knqxjnpb5y6zsl
Get alerted when CVE-2023-48362 or the next vulnerability affects your stack