What’s Vulnerable › Vulnerabilities

CVE-2023-4863: Google Chromium WebP Heap-Based Buffer Overflow Vulnerability

Description

Heap buffer overflow in libwebp in Google Chrome prior to 116.0.5845.187 and libwebp 1.3.2 allowed a remote attacker to perform an out of bounds memory write via a crafted HTML page. (Chromium security severity: Critical)

Affected products

How to fix

Upgrade to a fixed version: Bandisoft Honeyview 5.51; Bentley Seequent Leapfrog 2023.2; Google Chrome 116.0.5845.187; Microsoft Edge (Chromium) 116.0.1938.81; Microsoft Teams 1.6.00.26463, 1.6.00.26474; Microsoft WebP Image Extension 1.0.62681.0; Mozilla Firefox 102.15.1, 115.2.1, 117.0.1; Mozilla Thunderbird 102.15.1, 115.2.2; Chromium libwebp 1.3.2; Crates.Io Libwebp-Sys 0.9.3; Crates.Io Libwebp-Sys2 0.1.8; Crates.Io Webp 0.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4863 or the next vulnerability affects your stack