What’s Vulnerable › Vulnerabilities
CVE-2023-48631: Denial of Service of regular expression in package @adobe/css-tools
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-14 · updated 2026-06-17
- Weakness: CWE-20
Description
@adobe/css-tools versions 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.
Affected products
- Adobe Css-Tools: before 4.3.2 — fixed in 4.3.2
How to fix
Upgrade to a fixed version: Adobe Css-Tools 4.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2
- https://github.com/adobe/css-tools/security/advisories/GHSA-prr3-c3m5-p7q2
Get alerted when CVE-2023-48631 or the next vulnerability affects your stack