What’s Vulnerable › Vulnerabilities
CVE-2023-48674
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-170
Description
Dell Platform BIOS contains an Improper Null Termination vulnerability. A high privilege user with network access to the system could potentially send malicious data to the device in order to cause some services to cease to function.
Affected products
- Dell Latitude 5280 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 5288 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 5290 2-In-1 Firmware: before 1.32.0 — fixed in 1.32.0
- Dell Latitude 5290 Firmware: before 1.33.0 — fixed in 1.33.0
- Dell Latitude 5300 2-In-1 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 5300 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 5310 2-In-1 Firmware: before 1.22.0 — fixed in 1.22.0
- Dell Latitude 5310 Firmware: before 1.22.0 — fixed in 1.22.0
- Dell Latitude 5320 Firmware: before 1.36.0 — fixed in 1.36.0
- Dell Latitude 5330 Firmware: before 1.19.0 — fixed in 1.19.0
- Dell Latitude 5340 Firmware: before 1.10.1 — fixed in 1.10.1
- Dell Latitude 5400 Firmware: before 1.28.0 — fixed in 1.28.0
- Dell Latitude 5401 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 5410 Firmware: before 1.25.0 — fixed in 1.25.0
- Dell Latitude 5411 Firmware: before 1.26.0 — fixed in 1.26.0
- Dell Latitude 5420 Firmware: before 1.36.2 — fixed in 1.36.2
- Dell Latitude 5420 Rugged Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Latitude 5421 Firmware: before 1.27.1 — fixed in 1.27.1
- Dell Latitude 5424 Rugged Firmware: before 1.30.0 — fixed in 1.30.0
- Dell Latitude 5430 Firmware: before 1.19.0 — fixed in 1.19.0
- Dell Latitude 5430 Rugged Laptop Firmware: before 1.24.0 — fixed in 1.24.0
- Dell Latitude 5431 Firmware: before 1.19.0 — fixed in 1.19.0
- Dell Latitude 5440 Firmware: before 1.11.0 — fixed in 1.11.0
- Dell Latitude 5480 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 5488 Firmware: before 1.34.0 — fixed in 1.34.0
- Dell Latitude 5490 Firmware: before 1.33.0 — fixed in 1.33.0
- Dell Latitude 5491 Firmware: before 1.31.0 — fixed in 1.31.0
- Dell Latitude 5500 Firmware: before 1.28.0 — fixed in 1.28.0
- Dell Latitude 5501 Firmware: before 1.29.0 — fixed in 1.29.0
- Dell Latitude 5510 Firmware: before 1.25.0 — fixed in 1.25.0
How to fix
Upgrade to a fixed version: Dell Latitude 5280 Firmware 1.34.0; Dell Latitude 5288 Firmware 1.34.0; Dell Latitude 5290 2-In-1 Firmware 1.32.0; Dell Latitude 5290 Firmware 1.33.0; Dell Latitude 5300 2-In-1 Firmware 1.29.0; Dell Latitude 5300 Firmware 1.29.0; Dell Latitude 5310 2-In-1 Firmware 1.22.0; Dell Latitude 5310 Firmware 1.22.0; Dell Latitude 5320 Firmware 1.36.0; Dell Latitude 5330 Firmware 1.19.0; Dell Latitude 5340 Firmware 1.10.1; Dell Latitude 5400 Firmware 1.28.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000220410/dsa-2023-467
- https://www.dell.com/support/kbdoc/en-us/000220410/dsa-2023-467
Get alerted when CVE-2023-48674 or the next vulnerability affects your stack