What’s Vulnerable › Vulnerabilities
CVE-2023-48699: fastbots Eval Injection vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-95
Description
fastbots is a library for fast bot and scraper development using selenium and the Page Object Model (POM) design. Prior to version 0.1.5, an attacker could modify the locators.ini locator file with python code that without proper validation it's executed and it could lead to rce. The vulnerability is in the function `def __locator__(self, locator_name: str)` in `page.py`. In order to mitigate this issue, upgrade to fastbots version 0.1.5 or above.
Affected products
- ubertidavide fastbots: before 0.1.5 — fixed in 0.1.5
How to fix
Upgrade to a fixed version: ubertidavide fastbots 0.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/ubertidavide/fastbots/commit/73eb03bd75365e112b39877e26ef52853f5e9f57
- https://github.com/ubertidavide/fastbots/pull/3#issue-2003080806
- https://github.com/ubertidavide/fastbots/security/advisories/GHSA-vccg-f4gp-45x9
- https://github.com/ubertidavide/fastbots/commit/73eb03bd75365e112b39877e26ef52853f5e9f57
- https://github.com/ubertidavide/fastbots/pull/3#issue-2003080806
- https://github.com/ubertidavide/fastbots/security/advisories/GHSA-vccg-f4gp-45x9
Get alerted when CVE-2023-48699 or the next vulnerability affects your stack