What’s Vulnerable › Vulnerabilities
CVE-2023-48713: Knative Serving vulnerable to attacker-controlled pod causing denial of service of autoscaler
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-400
Description
Knative Serving builds on Kubernetes to support deploying and serving of applications and functions as serverless containers. An attacker who controls a pod to a degree where they can control the responses from the /metrics endpoint can cause Denial-of-Service of the autoscaler from an unbound memory allocation bug. This is a DoS vulnerability, where a non-privileged Knative user can cause a DoS for the cluster. This issue has been patched in version 0.39.0.
Affected products
- knative serving: before 1.10.5; from 1.11.0 before 1.11.3 — fixed in 1.10.5, 1.11.3
How to fix
Upgrade to a fixed version: knative serving 1.10.5, 1.11.3. Check the vendor advisory for mitigations.
References
- https://github.com/knative/serving/commit/012ee2509231b80b7842139bfabc30516d3026ca
- https://github.com/knative/serving/commit/101f814112b9ca0767f457e7e616b46205551cf1
- https://github.com/knative/serving/commit/fff40ef7bac9be8380ec3d1c70fc15b57093382a
- https://github.com/knative/serving/security/advisories/GHSA-qmvj-4qr9-v547
- https://github.com/knative/serving/commit/012ee2509231b80b7842139bfabc30516d3026ca
- https://github.com/knative/serving/commit/101f814112b9ca0767f457e7e616b46205551cf1
- https://github.com/knative/serving/commit/fff40ef7bac9be8380ec3d1c70fc15b57093382a
- https://github.com/knative/serving/security/advisories/GHSA-qmvj-4qr9-v547
Get alerted when CVE-2023-48713 or the next vulnerability affects your stack