What’s Vulnerable › Vulnerabilities
CVE-2023-48715: Tuleap vulnerable to Cross-site Scripting on the edition page of a release
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-79
Description
Tuleap is an open source suite to improve management of software developments and collaboration. Prior to version 15.2.99.103 of Tuleap Community Edition and prior to versions 15.2-4 and 15.1-8 of Tuleap Enterprise Edition, the name of the releases are not properly escaped on the edition page of a release. A malicious user with the ability to create a FRS release could force a victim having write permissions in the FRS to execute uncontrolled code. Tuleap Community Edition 15.2.99.103, Tuleap Enterprise Edition 15.2-4, and Tuleap Enterprise Edition 15.1-8 contain a fix for this issue.
Affected products
- Enalean tuleap: before 15.1-8; before 15.2.99.103; from 15.2 before 15.2-4 — fixed in 15.1-8, 15.2-4, 15.2.99.103
How to fix
Upgrade to a fixed version: Enalean tuleap 15.1-8, 15.2-4, 15.2.99.103. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/ea71ec7ee062aae8d1fa7a7325aaa759205c17d8
- https://github.com/Enalean/tuleap/security/advisories/GHSA-3m7g-7787-wc68
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=ea71ec7ee062aae8d1fa7a7325aaa759205c17d8
- https://tuleap.net/plugins/tracker/?aid=35143
- https://github.com/Enalean/tuleap/commit/ea71ec7ee062aae8d1fa7a7325aaa759205c17d8
- https://github.com/Enalean/tuleap/security/advisories/GHSA-3m7g-7787-wc68
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=ea71ec7ee062aae8d1fa7a7325aaa759205c17d8
- https://tuleap.net/plugins/tracker/?aid=35143
Get alerted when CVE-2023-48715 or the next vulnerability affects your stack