What’s Vulnerable › Vulnerabilities

CVE-2023-4895: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 12.0 to 16.7.6, all versions starting from 16.8 before 16.8.3, all versions starting from 16.9 before 16.9.1. This vulnerability allows for bypassing the 'group ip restriction' settings to access environment details of projects

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4895 or the next vulnerability affects your stack