What’s Vulnerable › Vulnerabilities
CVE-2023-49068: Apache DolphinScheduler: Information Leakage Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler.This issue affects Apache DolphinScheduler: before 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue. At the time of disclosure of this advisory, this version has not yet been released. In the mean time, we recommend you make sure the logs are only available to trusted operators.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/apache/dolphinscheduler/pull/15192
- https://lists.apache.org/thread/jn6kr6mjdgtfgpxoq9j8q4pkfsq8zmpq
- https://github.com/apache/dolphinscheduler/pull/15192
- https://lists.apache.org/thread/jn6kr6mjdgtfgpxoq9j8q4pkfsq8zmpq
Get alerted when CVE-2023-49068 or the next vulnerability affects your stack