What’s Vulnerable › Vulnerabilities
CVE-2023-49070: Pre-auth RCE in Apache Ofbiz 18.12.09 due to XML-RPC still present
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 95.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-94
Description
Pre-auth RCE in Apache Ofbiz 18.12.09. It's due to XML-RPC no longer maintained still present. This issue affects Apache OFBiz: before 18.12.10. Users are recommended to upgrade to version 18.12.10
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.10 — fixed in 18.12.10
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.10. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176323/Apache-OFBiz-18.12.09-Remote-Code-Execution.html
- https://issues.apache.org/jira/browse/OFBIZ-12812
- https://lists.apache.org/thread/jmbqk2lp4t4483whzndp5xqlq4f3otg3
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/release-notes-18.12.10.html
- https://ofbiz.apache.org/security.html
- http://packetstormsecurity.com/files/176323/Apache-OFBiz-18.12.09-Remote-Code-Execution.html
- https://issues.apache.org/jira/browse/OFBIZ-12812
- https://lists.apache.org/thread/jmbqk2lp4t4483whzndp5xqlq4f3otg3
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/release-notes-18.12.10.html
- https://ofbiz.apache.org/security.html
Get alerted when CVE-2023-49070 or the next vulnerability affects your stack