What’s Vulnerable › Vulnerabilities
CVE-2023-4911: GNU C Library Buffer Overflow Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-11-21
- EPSS: 63.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-03 · updated 2026-10-14
- Weakness: CWE-122
Description
A buffer overflow was discovered in the GNU C Library's dynamic loader ld.so while processing the GLIBC_TUNABLES environment variable. This issue could allow a local attacker to use maliciously crafted GLIBC_TUNABLES environment variables when launching binaries with SUID permission to execute code with elevated privileges.
Summary
CVE-2023-4911 is a buffer overflow in the GNU C Library dynamic loader ld.so when handling the GLIBC_TUNABLES environment variable, letting a local attacker run SUID binaries with malicious tunables to execute code with elevated privileges. It affects glibc (fixed in 2.39) and distributions including Ubuntu, Debian, and Fedora, plus several NetApp products. Exploitation is active and it is listed in CISA's Known Exploited Vulnerabilities catalog, with a public exploit available and a 63.8% EPSS probability of exploitation in 30 days. Apply vendor mitigations or patches immediately, or discontinue use of affected products where no mitigation exists.
CVE-2023-4911 هو تجاوز سعة المخزن المؤقت (buffer overflow) في محمّل المكتبات الديناميكي ld.so ضمن GNU C Library عند معالجة متغير البيئة GLIBC_TUNABLES، ما يسمح لمهاجم محلي بتشغيل ملفات ثنائية ذات صلاحية SUID باستخدام متغيرات خبيثة لتنفيذ تعليمات برمجية بصلاحيات مرتفعة. تؤثر الثغرة في glibc (تم إصلاحها في 2.39) وفي توزيعات منها Ubuntu وDebian وFedora، إضافة إلى عدة منتجات من NetApp. الاستغلال نشط فعلياً وهي مدرجة في كتالوج CISA للثغرات المعروفة بالاستغلال، مع وجود استغلال عام واحتمال استغلال 63.8% خلال 30 يوماً وفق EPSS. طبّق إجراءات التخفيف أو التحديثات وفق تعليمات المورّد فوراً، أو أوقف استخدام المنتجات المتأثرة إن لم تتوفر معالجات.
Affected products
- Canonical Ubuntu Linux: 22.04, 23.04
- Debian Linux: 11.0, 12.0
- Fedoraproject Fedora: 37, 38, 39
- GNU C Library (glibc): from 2.34 before 2.39 — fixed in 2.39
- NetApp Bootstrap Os: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp ONTAP Select Deploy administration utility: all versions
- RedHat Codeready Linux Builder: 9.0
- RedHat Codeready Linux Builder Eus: 8.6, 9.2, 9.4, 9.6
- RedHat Codeready Linux Builder For Arm64: 9.0_aarch64
- RedHat Codeready Linux Builder For Arm64 Eus: 8.6, 9.2_aarch64, 9.4_aarch64, 9.6_aarch64
- RedHat Codeready Linux Builder For Ibm Z Systems: 9.0_s390x
- RedHat Codeready Linux Builder For Ibm Z Systems Eus: 8.6, 9.2_s390x, 9.4_s390x, 9.6_s390x
- RedHat Codeready Linux Builder For Power Little Endian: 9.0_ppc64le
- RedHat Codeready Linux Builder For Power Little Endian Eus: 8.6, 9.2_ppc64le, 9.4_ppc64le, 9.6_ppc64le
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Enterprise Linux Eus: 8.6, 9.2, 9.4, 9.6
- RedHat Enterprise Linux For Arm 64: 9.0_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 8.6_aarch64, 9.2_aarch64, 9.4_aarch64, 9.6_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 9.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.2_s390x, 9.4_s390x, 9.6_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus S390X: 8.6
- RedHat Enterprise Linux For Power Big Endian Eus: 8.6_ppc64le
- RedHat Enterprise Linux For Power Little Endian: 9.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 9.2_ppc64le, 9.4_ppc64le, 9.6_ppc64le
- RedHat Enterprise Linux Server Aus: 8.6, 9.2, 9.4, 9.6
How to fix
Upgrade to a fixed version: GNU C Library (glibc) 2.39; Siemens Simatic S7-1500 Tm Mfp Firmware 1.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2023:5453
- https://access.redhat.com/errata/RHSA-2023:5454
- https://access.redhat.com/errata/RHSA-2023:5455
- https://access.redhat.com/errata/RHSA-2023:5476
- https://access.redhat.com/errata/RHSA-2024:0033
- https://access.redhat.com/security/cve/CVE-2023-4911
- https://bugzilla.redhat.com/show_bug.cgi?id=2238352
- https://www.qualys.com/2023/10/03/cve-2023-4911/looney-tunables-local-privilege-escalation-glibc-ld-so.txt
- https://www.qualys.com/cve-2023-4911/
- http://packetstormsecurity.com/files/174986/glibc-ld.so-Local-Privilege-Escalation.html
- http://packetstormsecurity.com/files/176288/Glibc-Tunables-Privilege-Escalation.html
- http://seclists.org/fulldisclosure/2023/Oct/11
Get alerted when CVE-2023-4911 or the next vulnerability affects your stack