What’s Vulnerable › Vulnerabilities

CVE-2023-49145: Apache NiFi: Improper Neutralization of Input in Advanced User Interface for Jolt

Description

Apache NiFi 0.7.0 through 1.23.2 include the JoltTransformJSON Processor, which provides an advanced configuration user interface that is vulnerable to DOM-based cross-site scripting. If an authenticated user, who is authorized to configure a JoltTransformJSON Processor, visits a crafted URL, then arbitrary JavaScript code can be executed within the session context of the authenticated user. Upgrading to Apache NiFi 1.24.0 or 2.0.0-M1 is the recommended mitigation.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache NiFi 1.24.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-49145 or the next vulnerability affects your stack