What’s Vulnerable › Vulnerabilities
CVE-2023-49168: WordPress BP Better Messages Plugin <= 2.4.0 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WordPlus Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss allows Stored XSS.This issue affects Better Messages – Live Chat for WordPress, BuddyPress, PeepSo, Ultimate Member, BuddyBoss: from n/a through 2.4.0.
Affected products
- wordplus Better Messages – Live Chat, Chat Rooms, Real-Time Messaging & Private Messages: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: wordplus Better Messages – Live Chat, Chat Rooms, Real-Time Messaging & Private Messages 2.4.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bp-better-messages/wordpress-bp-better-messages-plugin-2-3-12-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/bp-better-messages/wordpress-bp-better-messages-plugin-2-3-12-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-49168 or the next vulnerability affects your stack