What’s Vulnerable › Vulnerabilities
CVE-2023-4919: iframe <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'iframe' Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.
Affected products
- webvitaly iframe: before 4.7 — fixed in 4.7
How to fix
Upgrade to a fixed version: webvitaly iframe 4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L28
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L40
- https://plugins.trac.wordpress.org/changeset/2970787/iframe#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3706deed-55f2-4dfb-bfed-7a14872cd15a?source=cve
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L28
- https://plugins.trac.wordpress.org/browser/iframe/tags/4.5/iframe.php#L40
- https://plugins.trac.wordpress.org/changeset/2970787/iframe#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3706deed-55f2-4dfb-bfed-7a14872cd15a?source=cve
Get alerted when CVE-2023-4919 or the next vulnerability affects your stack