What’s Vulnerable › Vulnerabilities
CVE-2023-4921: Use-after-free in Linux kernel's net/sched: sch_qfq component
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-12 · updated 2026-10-14
- Weakness: CWE-416
Description
A use-after-free vulnerability in the Linux kernel's net/sched: sch_qfq component can be exploited to achieve local privilege escalation. When the plug qdisc is used as a class of the qfq qdisc, sending network packets triggers use-after-free in qfq_dequeue() due to the incorrect .peek handler of sch_plug and lack of error checking in agg_dequeue(). We recommend upgrading past commit 8fc134fee27f2263988ae38920bc03da416b03d8.
Affected products
- Debian Linux: 10.0
- Linux kernel: from 3.8 before 4.14.326; from 4.15 before 4.19.295; from 4.20 before 5.4.257; from 5.5 before 5.10.195; from 5.11 before 5.15.132; from 5.16 before 6.1.54 — fixed in 4.14.326, 4.19.295, 5.10.195, 5.15.132, 5.4.257, 6.1.54
How to fix
Upgrade to a fixed version: Linux kernel 4.14.326, 4.19.295, 5.10.195, 5.15.132. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=8fc134fee27f2263988ae38920bc03da416b03d8
- https://kernel.dance/8fc134fee27f2263988ae38920bc03da416b03d8
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=8fc134fee27f2263988ae38920bc03da416b03d8
- https://kernel.dance/8fc134fee27f2263988ae38920bc03da416b03d8
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2024/01/msg00004.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-769027.html
- https://cert-portal.siemens.com/productcert/html/ssa-794697.html
Get alerted when CVE-2023-4921 or the next vulnerability affects your stack