What’s Vulnerable › Vulnerabilities

CVE-2023-49213

Description

The API endpoints in Ironman PowerShell Universal 3.0.0 through 4.2.0 allow remote attackers to execute arbitrary commands via crafted HTTP requests if a param block is used, due to invalid sanitization of input strings. The fixed versions are 3.10.2, 4.1.10, and 4.2.1.

Affected products

How to fix

Upgrade to a fixed version: Ironmansoftware Powershell Universal 3.10.2, 4.1.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-49213 or the next vulnerability affects your stack