What’s Vulnerable › Vulnerabilities
CVE-2023-49250: Apache DolphinScheduler: Insecure TLS TrustManager used in HttpUtil
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-20 · updated 2026-06-17
- Weakness: CWE-295
Description
Because the HttpUtils class did not verify certificates, an attacker that could perform a Man-in-the-Middle (MITM) attack on outgoing https connections could impersonate the server. This issue affects Apache DolphinScheduler: before 3.2.0. Users are recommended to upgrade to version 3.2.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.2.1 — fixed in 3.2.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.2.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/20/1
- https://github.com/apache/dolphinscheduler/pull/15288
- https://lists.apache.org/thread/wgs2jvhbmq8xnd6rmg0ymz73nyj7b3qn
- http://www.openwall.com/lists/oss-security/2024/02/20/1
- https://github.com/apache/dolphinscheduler/pull/15288
- https://lists.apache.org/thread/wgs2jvhbmq8xnd6rmg0ymz73nyj7b3qn
Get alerted when CVE-2023-49250 or the next vulnerability affects your stack