What’s Vulnerable › Vulnerabilities
CVE-2023-49276: Attribute Injection leading to XSS(Cross-Site-Scripting) in uptime-kuma
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Uptime Kuma is an open source self-hosted monitoring tool. In affected versions the Google Analytics element in vulnerable to Attribute Injection leading to Cross-Site-Scripting (XSS). Since the custom status interface can set an independent Google Analytics ID and the template has not been sanitized, there is an attribute injection vulnerability here, which can lead to XSS attacks. This vulnerability has been addressed in commit `f28dccf4e` which is included in release version 1.23.7. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Uptime.Kuma Uptime Kuma: from 1.20.0 before 1.23.7 — fixed in 1.23.7
How to fix
Upgrade to a fixed version: Uptime.Kuma Uptime Kuma 1.23.7. Check the vendor advisory for mitigations.
References
- https://github.com/louislam/uptime-kuma/commit/f28dccf4e11f041564293e4f407e69ab9ee2277f
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-v4v2-8h88-65qj
- https://github.com/louislam/uptime-kuma/commit/f28dccf4e11f041564293e4f407e69ab9ee2277f
- https://github.com/louislam/uptime-kuma/security/advisories/GHSA-v4v2-8h88-65qj
Get alerted when CVE-2023-49276 or the next vulnerability affects your stack