What’s Vulnerable › Vulnerabilities
CVE-2023-49277: Reflected Cross-site Scripting Vulnerability in dpaste
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
dpaste is an open source pastebin application written in Python using the Django framework. A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.
Affected products
- DarrenOfficial dpaste: before 3.8 — fixed in 3.8
How to fix
Upgrade to a fixed version: DarrenOfficial dpaste 3.8. Check the vendor advisory for mitigations.
References
- https://github.com/DarrenOfficial/dpaste/commit/44a666a79b3b29ed4f340600bfcf55113bfb7086
- https://github.com/DarrenOfficial/dpaste/security/advisories/GHSA-r8j9-5cj7-cv39
- https://github.com/DarrenOfficial/dpaste/commit/44a666a79b3b29ed4f340600bfcf55113bfb7086
- https://github.com/DarrenOfficial/dpaste/security/advisories/GHSA-r8j9-5cj7-cv39
Get alerted when CVE-2023-49277 or the next vulnerability affects your stack