What’s Vulnerable › Vulnerabilities
CVE-2023-49285: Denial of Service in HTTP Message Processing in Squid
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 88.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-04 · updated 2026-06-17
- Weakness: CWE-126
Description
Squid is a caching proxy for the Web supporting HTTP, HTTPS, FTP, and more. Due to a Buffer Overread bug Squid is vulnerable to a Denial of Service attack against Squid HTTP Message processing. This bug is fixed by Squid version 6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Squid: through 6.4
References
- http://www.squid-cache.org/Versions/v5/SQUID-2023_7.patch
- http://www.squid-cache.org/Versions/v6/SQUID-2023_7.patch
- https://github.com/squid-cache/squid/commit/77b3fb4df0f126784d5fd4967c28ed40eb8d521b
- https://github.com/squid-cache/squid/commit/deee944f9a12c9fd399ce52f3e2526bb573a9470
- https://github.com/squid-cache/squid/security/advisories/GHSA-8w9r-p88v-mmx9
- https://lists.debian.org/debian-lts-announce/2024/01/msg00003.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/A5QASTMCUSUEW3UOMKHZJB3FTONWSRXS/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MEV66D3PAAY6K7TWDT3WZBLCPLASFJDC/
- https://security.netapp.com/advisory/ntap-20240119-0004/
- http://www.squid-cache.org/Versions/v5/SQUID-2023_7.patch
- http://www.squid-cache.org/Versions/v6/SQUID-2023_7.patch
- https://github.com/squid-cache/squid/commit/77b3fb4df0f126784d5fd4967c28ed40eb8d521b
Get alerted when CVE-2023-49285 or the next vulnerability affects your stack