What’s Vulnerable › Vulnerabilities
CVE-2023-49289: Cross-site Scripting in Ajax.NET Professional
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Ajax.NET Professional (AjaxPro) is an AJAX framework for Microsoft ASP.NET which will create proxy JavaScript classes that are used on client-side to invoke methods on the web server. Affected versions of this package are vulnerable cross site scripting attacks. Releases before version 21.12.22.1 are affected. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- michaelschwarz Ajax.Net Professional: before 21.12.22.1 — fixed in 21.12.22.1
How to fix
Upgrade to a fixed version: michaelschwarz Ajax.Net Professional 21.12.22.1. Check the vendor advisory for mitigations.
References
- https://github.com/michaelschwarz/Ajax.NET-Professional/commit/c89e39b9679fcb8ab6644fe21cc7e652cb615e2b
- https://github.com/michaelschwarz/Ajax.NET-Professional/security/advisories/GHSA-8v6j-gc74-fmpp
- https://www.nuget.org/packages/AjaxNetProfessional/
- https://github.com/michaelschwarz/Ajax.NET-Professional/commit/c89e39b9679fcb8ab6644fe21cc7e652cb615e2b
- https://github.com/michaelschwarz/Ajax.NET-Professional/security/advisories/GHSA-8v6j-gc74-fmpp
- https://www.nuget.org/packages/AjaxNetProfessional/
Get alerted when CVE-2023-49289 or the next vulnerability affects your stack