What’s Vulnerable › Vulnerabilities

CVE-2023-49294: Asterisk Path Traversal vulnerability

Description

Asterisk is an open source private branch exchange and telephony toolkit. In Asterisk prior to versions 18.20.1, 20.5.1, and 21.0.1, as well as certified-asterisk prior to 18.9-cert6, it is possible to read any arbitrary file even when the `live_dangerously` is not enabled. This allows arbitrary files to be read. Asterisk versions 18.20.1, 20.5.1, and 21.0.1, as well as certified-asterisk prior to 18.9-cert6, contain a fix for this issue.

Affected products

How to fix

Upgrade to a fixed version: Digium Asterisk 18.20.1, 20.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-49294 or the next vulnerability affects your stack