What’s Vulnerable › Vulnerabilities
CVE-2023-49299: Apache DolphinScheduler: Arbitrary js execute as root for authenticated users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-30 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can cause arbitrary, unsandboxed javascript to be executed on the server.This issue affects Apache DolphinScheduler: until 3.1.9. Users are recommended to upgrade to version 3.1.9, which fixes the issue.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.1.9 — fixed in 3.1.9
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.1.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/23/3
- https://github.com/apache/dolphinscheduler/pull/15228
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm
- http://www.openwall.com/lists/oss-security/2024/02/23/3
- https://github.com/apache/dolphinscheduler/pull/15228
- https://lists.apache.org/thread/tnf99qoc6tlnwrny4t1zk6mfszgdsokm
Get alerted when CVE-2023-49299 or the next vulnerability affects your stack