What’s Vulnerable › Vulnerabilities
CVE-2023-49316
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-834
Description
In Math/BinaryField.php in phpseclib 3 before 3.0.34, excessively large degrees can lead to a denial of service.
Affected products
- phpseclib: from 3.0.0 before 3.0.34 — fixed in 3.0.34
How to fix
Upgrade to a fixed version: phpseclib 3.0.34. Check the vendor advisory for mitigations.
References
- https://github.com/phpseclib/phpseclib/commit/964d78101a70305df33f442f5490f0adb3b7e77f
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.34
- https://github.com/phpseclib/phpseclib/commit/964d78101a70305df33f442f5490f0adb3b7e77f
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.34
Get alerted when CVE-2023-49316 or the next vulnerability affects your stack