What’s Vulnerable › Vulnerabilities
CVE-2023-4947: WooCommerce EAN Payment Gateway < 6.1.0 - Missing Authorization to Authenticated (Contributor+) EAN Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-862
Description
The WooCommerce EAN Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the refresh_order_ean_data AJAX action in versions up to 6.1.0. This makes it possible for authenticated attackers with contributor-level access and above, to update EAN numbers for orders.
Affected products
- Yan&Co WooCommerce EAN Payment Gateway: before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: Yan&Co WooCommerce EAN Payment Gateway 6.1.0. Check the vendor advisory for mitigations.
References
- https://plugins.yanco.dk/product/woocommerce-ean-payment-gateway/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2760b183-3c15-4f0e-b72f-7c0333f9d4b6?source=cve
- https://plugins.yanco.dk/product/woocommerce-ean-payment-gateway/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2760b183-3c15-4f0e-b72f-7c0333f9d4b6?source=cve
Get alerted when CVE-2023-4947 or the next vulnerability affects your stack