What’s Vulnerable › Vulnerabilities
CVE-2023-49566: Apache Linkis DataSource: JDBC Datasource Module with DB2 has JNDI Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-15 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <=1.5.0, due to the lack of effective filtering of parameters, an attacker configuring malicious db2 parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis <=1.5.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.
Affected products
- Apache Software Foundation Apache Linkis: from 1.4.0 before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Linkis 1.6.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/t68yy52lmv7pxgrxnq6rw7rwvk9tb1xj
- http://www.openwall.com/lists/oss-security/2024/07/13/5
- https://lists.apache.org/thread/t68yy52lmv7pxgrxnq6rw7rwvk9tb1xj
Get alerted when CVE-2023-49566 or the next vulnerability affects your stack