What’s Vulnerable › Vulnerabilities
CVE-2023-49594
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-23 · updated 2026-06-17
- Weakness: CWE-201
Description
An information disclosure vulnerability exists in the challenge functionality of instipod DuoUniversalKeycloakAuthenticator 1.0.7 plugin. A specially crafted HTTP request can lead to a disclosure of sensitive information. A user logging into Keycloak using DuoUniversalKeycloakAuthenticator plugin triggers this vulnerability.
Affected products
- instipod DuoUniversalKeycloakAuthenticator: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: instipod DuoUniversalKeycloakAuthenticator 1.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/instipod/DuoUniversalKeycloakAuthenticator/releases/tag/1.0.8
- https://talosintelligence.com/vulnerability_reports/TALOS-2023-1907
- https://github.com/instipod/DuoUniversalKeycloakAuthenticator/releases/tag/1.0.8
- https://talosintelligence.com/vulnerability_reports/TALOS-2023-1907
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2023-1907
Get alerted when CVE-2023-49594 or the next vulnerability affects your stack