What’s Vulnerable › Vulnerabilities
CVE-2023-4961: Poptin <= 1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Poptin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'poptin-form' shortcode in versions up to, and including, 1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Poptin – Exit Pop Ups & Email Popups: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Poptin – Exit Pop Ups & Email Popups 1.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/poptin/tags/1.3/poptin.php#L659
- https://plugins.trac.wordpress.org/changeset/2968210/poptin#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/778af777-4c98-45cd-9704-1bdc96054aa7?source=cve
- https://plugins.trac.wordpress.org/browser/poptin/tags/1.3/poptin.php#L659
- https://plugins.trac.wordpress.org/changeset/2968210/poptin#file2
- https://www.wordfence.com/threat-intel/vulnerabilities/id/778af777-4c98-45cd-9704-1bdc96054aa7?source=cve
Get alerted when CVE-2023-4961 or the next vulnerability affects your stack