What’s Vulnerable › Vulnerabilities
CVE-2023-49652
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-29 · updated 2026-06-17
- Weakness: CWE-862
Description
Incorrect permission checks in Jenkins Google Compute Engine Plugin 4.550.vb_327fca_3db_11 and earlier allow attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate system-scoped credentials IDs of credentials stored in Jenkins and to connect to Google Cloud Platform using attacker-specified credentials IDs obtained through another method, to obtain information about existing projects. This fix has been backported to 4.3.17.1.
Affected products
- Jenkins project Jenkins Google Compute Engine Plugin: before 4.3.17.1 — fixed in 4.3.17.1
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Google Compute Engine Plugin 4.3.17.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/29/1
- https://www.jenkins.io/security/advisory/2023-11-29/#SECURITY-2835
- http://www.openwall.com/lists/oss-security/2023/11/29/1
- https://www.jenkins.io/security/advisory/2023-11-29/#SECURITY-2835
Get alerted when CVE-2023-49652 or the next vulnerability affects your stack