What’s Vulnerable › Vulnerabilities
CVE-2023-49657: Apache Superset: Stored XSS in Dashboard Title and Chart Title
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-23 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in Apache Superset before 3.0.3. An authenticated attacker with create/update permissions on charts or dashboards could store a script or add a specific HTML snippet that would act as a stored XSS. For 2.X versions, users should change their config to include: TALISMAN_CONFIG = { "content_security_policy": { "base-uri": ["'self'"], "default-src": ["'self'"], "img-src": ["'self'", "blob:", "data:"], "worker-src": ["'self'", "blob:"], "connect-src": [ "'self'", " https://api.mapbox.com" https://api.mapbox.com" ;, " https://events.mapbox.com" https://events.mapbox.com" ;, ], "object-src": "'none'", "style-src": [ "'self'", "'unsafe-inline'", ], "script-src": ["'self'", "'strict-dynamic'"], }, "content_security_policy_nonce_in": ["script-src"], "force_https": False, "session_cookie_secure": False, }
Affected products
- Apache Superset: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: Apache Superset 3.0.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/wjyvz8om9nwd396lh0bt156mtwjxpsvx
- https://lists.apache.org/thread/wjyvz8om9nwd396lh0bt156mtwjxpsvx
Get alerted when CVE-2023-49657 or the next vulnerability affects your stack