What’s Vulnerable › Vulnerabilities
CVE-2023-49733: Apache Cocoon's StreamGenerator is vulnerable to XXE injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-30 · updated 2026-06-17
- Weakness: CWE-611
Description
Improper Restriction of XML External Entity Reference vulnerability in Apache Cocoon.This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Cocoon: from 2.2.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cocoon 2.3.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/30/5
- https://lists.apache.org/thread/t87nntzt6dxw354zbqr9k7l7o1x8gq11
- http://www.openwall.com/lists/oss-security/2023/11/30/5
- https://lists.apache.org/thread/t87nntzt6dxw354zbqr9k7l7o1x8gq11
Get alerted when CVE-2023-49733 or the next vulnerability affects your stack