What’s Vulnerable › Vulnerabilities
CVE-2023-49734: Apache Superset: Privilege Escalation Vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-863
Description
An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.
Affected products
- Apache Superset: before 2.1.2; from 3.0.0 before 3.0.2 — fixed in 2.1.2, 3.0.2
How to fix
Upgrade to a fixed version: Apache Superset 2.1.2, 3.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/12/19/3
- https://lists.apache.org/thread/985h6ltvtbvdoysso780kkj7x744cds5
- http://www.openwall.com/lists/oss-security/2023/12/19/3
- https://lists.apache.org/thread/985h6ltvtbvdoysso780kkj7x744cds5
Get alerted when CVE-2023-49734 or the next vulnerability affects your stack