What’s Vulnerable › Vulnerabilities
CVE-2023-49736: Apache Superset: SQL Injection on where_in JINJA macro
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-89
Description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
Affected products
- Apache Superset: before 2.1.2; from 3.0.0 before 3.0.2 — fixed in 2.1.2, 3.0.2
How to fix
Upgrade to a fixed version: Apache Superset 2.1.2, 3.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/12/19/2
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1p
- http://www.openwall.com/lists/oss-security/2023/12/19/2
- https://lists.apache.org/thread/1kf481bgs3451qcz6hfhobs7xvhp8n1p
Get alerted when CVE-2023-49736 or the next vulnerability affects your stack