What’s Vulnerable › Vulnerabilities
CVE-2023-4977: Code Injection in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-94
Description
Code Injection in GitHub repository librenms/librenms prior to 23.9.0.
Affected products
- librenms: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: librenms 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/1194934d31c795a3f6877a96ffaa34b1f475bdd0
- https://huntr.dev/bounties/3db8a1a4-ca2d-45df-be18-a959ebf82fbc
- https://github.com/librenms/librenms/commit/1194934d31c795a3f6877a96ffaa34b1f475bdd0
- https://huntr.dev/bounties/3db8a1a4-ca2d-45df-be18-a959ebf82fbc
Get alerted when CVE-2023-4977 or the next vulnerability affects your stack