What’s Vulnerable › Vulnerabilities
CVE-2023-4978: Cross-site Scripting (XSS) - DOM in librenms/librenms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository librenms/librenms prior to 23.9.0.
Affected products
- librenms: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: librenms 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/e4c46a45364cb944b94abf9b83f0558b2c4c2fb7
- https://huntr.dev/bounties/cefd9295-2053-4e6e-a130-7e1f845728f4
- https://github.com/librenms/librenms/commit/e4c46a45364cb944b94abf9b83f0558b2c4c2fb7
- https://huntr.dev/bounties/cefd9295-2053-4e6e-a130-7e1f845728f4
Get alerted when CVE-2023-4978 or the next vulnerability affects your stack