What’s Vulnerable › Vulnerabilities
CVE-2023-4979: Cross-site Scripting (XSS) - Reflected in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository librenms/librenms prior to 23.9.0.
Affected products
- librenms: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: librenms 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/49d66fa31b43acef02eaa09ee9af15fe7e16cd03
- https://huntr.dev/bounties/e67f8f5d-4048-404f-9b86-cb6b8719b77f
- https://github.com/librenms/librenms/commit/49d66fa31b43acef02eaa09ee9af15fe7e16cd03
- https://huntr.dev/bounties/e67f8f5d-4048-404f-9b86-cb6b8719b77f
Get alerted when CVE-2023-4979 or the next vulnerability affects your stack