What’s Vulnerable › Vulnerabilities

CVE-2023-49791: Workflows do not require password confirmation on API level

Description

Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when an attacker manages to get access to an active session of another user via another way, they could delete and modify workflows by sending calls directly to the API bypassing the password confirmation shown in the UI. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-49791 or the next vulnerability affects your stack