What’s Vulnerable › Vulnerabilities
CVE-2023-49792: Bruteforce protection can be bypassed with misconfigured proxy
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-307
Description
Nextcloud Server provides data storage for Nextcloud, an open source cloud platform. In Nextcloud Server prior to versions 26.0.9 and 27.1.4; as well as Nextcloud Enterprise Server prior to versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4; when a (reverse) proxy is configured as trusted proxy the server could be tricked into reading a wrong remote address for an attacker, allowing them executing authentication attempts than intended. Nextcloud Server versions 26.0.9 and 27.1.4 and Nextcloud Enterprise Server versions 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, and 27.1.4 contain a patch for this issue. No known workarounds are available.
Affected products
- Nextcloud Server: from 23.0.0 before 23.0.12.13; from 24.0.0 before 24.0.12.9; from 25.0.0 before 25.0.13.4; from 26.0.0 before 26.0.9; from 27.0.0 before 27.1.4 — fixed in 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9, 27.1.4
How to fix
Upgrade to a fixed version: Nextcloud Server 23.0.12.13, 24.0.12.9, 25.0.13.4, 26.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5j2p-q736-hw98
- https://github.com/nextcloud/server/pull/41526
- https://hackerone.com/reports/2230915
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5j2p-q736-hw98
- https://github.com/nextcloud/server/pull/41526
- https://hackerone.com/reports/2230915
Get alerted when CVE-2023-49792 or the next vulnerability affects your stack