What’s Vulnerable › Vulnerabilities
CVE-2023-49802: MantisBT LinkedCustomFields Cross-site Scripting vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The LinkedCustomFields plugin for MantisBT allows users to link values between two custom fields, creating linked drop-downs. Prior to version 2.0.1, cross-site scripting in the MantisBT LinkedCustomFields plugin allows Javascript execution, when a crafted Custom Field is linked via the plugin and displayed when reporting a new Issue or editing an existing one. This issue is fixed in version 2.0.1. As a workaround, one may utilize MantisBT's default Content Security Policy, which blocks script execution.
Affected products
- mantisbt-plugins LinkedCustomFields: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: mantisbt-plugins LinkedCustomFields 2.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/mantisbt-plugins/LinkedCustomFields/commit/30e5ae751e40d7ae18bfd794fd48671477b3d286
- https://github.com/mantisbt-plugins/LinkedCustomFields/issues/10
- https://github.com/mantisbt-plugins/LinkedCustomFields/pull/11
- https://github.com/mantisbt-plugins/LinkedCustomFields/security/advisories/GHSA-2f37-9xpx-5hhw
- https://github.com/mantisbt-plugins/LinkedCustomFields/commit/30e5ae751e40d7ae18bfd794fd48671477b3d286
- https://github.com/mantisbt-plugins/LinkedCustomFields/issues/10
- https://github.com/mantisbt-plugins/LinkedCustomFields/pull/11
- https://github.com/mantisbt-plugins/LinkedCustomFields/security/advisories/GHSA-2f37-9xpx-5hhw
Get alerted when CVE-2023-49802 or the next vulnerability affects your stack