What’s Vulnerable › Vulnerabilities
CVE-2023-49803: @koa/cors has overly permissive origin policy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-346
Description
@koa/cors npm provides Cross-Origin Resource Sharing (CORS) for koa, a web framework for Node.js. Prior to version 5.0.0, the middleware operates in a way that if an allowed origin is not provided, it will return an `Access-Control-Allow-Origin` header with the value of the origin from the request. This behavior completely disables one of the most crucial elements of browsers - the Same Origin Policy (SOP), this could cause a very serious security threat to the users of this middleware. If such behavior is expected, for instance, when middleware is used exclusively for prototypes and not for production applications, it should be heavily emphasized in the documentation along with an indication of the risks associated with such behavior, as many users may not be aware of it. Version 5.0.0 fixes this vulnerability.
Affected products
- koajs Cross-Origin Resource Sharing For Koa: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: koajs Cross-Origin Resource Sharing For Koa 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/koajs/cors/commit/f31dac99f5355c41e7d4dd3c4a80c5f154941a11
- https://github.com/koajs/cors/security/advisories/GHSA-qxrj-hx23-xp82
- https://github.com/koajs/cors/commit/f31dac99f5355c41e7d4dd3c4a80c5f154941a11
- https://github.com/koajs/cors/security/advisories/GHSA-qxrj-hx23-xp82
Get alerted when CVE-2023-49803 or the next vulnerability affects your stack