What’s Vulnerable › Vulnerabilities
CVE-2023-4981: Cross-site Scripting (XSS) - DOM in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository librenms/librenms prior to 23.9.0.
Affected products
- librenms: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: librenms 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/03c4da62c8acde0a82acbb4a445ae866ebfdd3f7
- https://huntr.dev/bounties/1f014494-49a9-4bf0-8d43-a675498b9609
- https://github.com/librenms/librenms/commit/03c4da62c8acde0a82acbb4a445ae866ebfdd3f7
- https://huntr.dev/bounties/1f014494-49a9-4bf0-8d43-a675498b9609
Get alerted when CVE-2023-4981 or the next vulnerability affects your stack