What’s Vulnerable › Vulnerabilities
CVE-2023-4982: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 23.9.0.
Affected products
- librenms: before 23.9.0 — fixed in 23.9.0
How to fix
Upgrade to a fixed version: librenms 23.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/2c5960631c49f7414f61b6d4dcd305b07da05769
- https://huntr.dev/bounties/d3c2dd8a-883c-400e-a1a7-326c3fd37b9e
- https://github.com/librenms/librenms/commit/2c5960631c49f7414f61b6d4dcd305b07da05769
- https://huntr.dev/bounties/d3c2dd8a-883c-400e-a1a7-326c3fd37b9e
Get alerted when CVE-2023-4982 or the next vulnerability affects your stack