What’s Vulnerable › Vulnerabilities
CVE-2023-49828: WordPress WooCommerce Payments Plugin <= 6.4.2 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo allows Stored XSS.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 6.4.2.
Affected products
- Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo: before 6.5.0 — fixed in 6.5.0
How to fix
Upgrade to a fixed version: Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo 6.5.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woocommerce-payments/wordpress-woopayments-plugin-6-4-2-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woocommerce-payments/wordpress-woopayments-plugin-6-4-2-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-49828 or the next vulnerability affects your stack