What’s Vulnerable › Vulnerabilities
CVE-2023-49920: Apache Airflow: Missing CSRF protection on DAG/trigger
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-21 · updated 2026-06-17
- Weakness: CWE-352
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
Affected products
- Apache Airflow: from 2.7.0 through 2.7.3
References
- http://www.openwall.com/lists/oss-security/2023/12/21/3
- https://github.com/apache/airflow/pull/36026
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq
- http://www.openwall.com/lists/oss-security/2023/12/21/3
- https://github.com/apache/airflow/pull/36026
- https://lists.apache.org/thread/mnwd2vcfw3gms6ft6kl951vfbqrxsnjq
Get alerted when CVE-2023-49920 or the next vulnerability affects your stack