What’s Vulnerable › Vulnerabilities
CVE-2023-49952
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Mastodon 4.1.x before 4.1.17 and 4.2.x before 4.2.9 allows a bypass of rate limiting via a crafted HTTP request header.
Affected products
- mastodon: from 4.1.0 before 4.1.17; from 4.2.0 before 4.2.9 — fixed in 4.1.17, 4.2.9
How to fix
Upgrade to a fixed version: mastodon 4.1.17, 4.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/mastodon/mastodon/security
- https://github.com/mastodon/mastodon/security/advisories/GHSA-c2r5-cfqr-c553
Get alerted when CVE-2023-49952 or the next vulnerability affects your stack