What’s Vulnerable › Vulnerabilities
CVE-2023-4997: Improper authorisation in Uptime DC
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-04 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper authorisation of regular users in ProIntegra Uptime DC software (versions below 2.0.0.33940) allows them to change passwords of all other users including administrators leading to a privilege escalation.
Affected products
- ProIntegra S.A. UptimeDC: before 2.0.0.33940 — fixed in 2.0.0.33940
How to fix
Upgrade to a fixed version: ProIntegra S.A. UptimeDC 2.0.0.33940. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2023/10/CVE-2023-4997/
- https://cert.pl/posts/2023/10/CVE-2023-4997/
- https://cert.pl/en/posts/2023/10/CVE-2023-4997/
- https://cert.pl/posts/2023/10/CVE-2023-4997/
Get alerted when CVE-2023-4997 or the next vulnerability affects your stack